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Creating a Data File

Creating New Variables

First click on the VariableView tab on the lower left- hand corner of your screen
This is where you enter in your new variables.

Under Name enter in the name of your variable. The name may need to be
abbreviated since SPSS only alows 8 letters (e.g., “type of schooling” may need
to be entered as “school”). It isusually best to start with an ID or name variable
so that you can keep track of your cases.

For the following columns, clicking on the box will cause a small gray box to
appear on theright-hand side. You will need to click on the gray box to
changethe settings. After entering in the name and clicking on tab, the
default settings for the other columnswill pop up.

Under Type be surethat Numeric is selected if your datais numeric or ordinal, or
if you will be using codes (e.g. 1 = male, 2 = female). If you want to be able to
type in letters instead of numbers, you need to click on String, then click on Ok.
Under Width be sure the column will be wide enough to enter in the given values
(the default setting usually is wide enough so you can ignore this).

Under Decimals be sure thereis the right number of places past the decimal. 1f
you want things to show up as whole numbers, change the Decimals to zero, if
you want it to the one' s digit, set it to one, etc.

Under Labels enter in the entire name of the variable so thet you know what it is.
(e.g. type in “Type of schooling” instead of just “school”).

Valuesiswhere you enter in your codes. Click on the gray box. Next to Value
type in the numerical code (e.g. 1). Next to Value Label type in what that
number represents (e.g. Male). Then click Add. Once you have entered in all of
the codes, click on Ok.

You don’t really need to do anything with the next three columns (Missing,
Columns, and Align).

For Measure make sure the correct level of measurement is selected (usualy the
default setting will make it correct).

Entering the Data

When all of the variables have been entered, click on the Data Viewtab in the
lower left-hand corner of your screen.

Y our new variables will appear horizontally, across the top of the data sheet
instead of verticaly.

Enter in the numerical values.
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Determining Which Test to Use

Step 1: Which type of data do you have?

Step 2:

When you are determining which type of data you have, remember that you are
looking at the Dependent Variable, or in other words, the variable that measures
the difference (or the relationship for correlations). For example, if you are
looking at the difference between men and women in how well they scored on the
SAT’s, their score on the SAT is the dependent variable because it is the one that
you are measuring in order to determine if there is a difference.

Nominal Data: Numbers or words that are used merely as labels. Some examples
of nominal data are types of religion (Christian, Catholic, Jewish, etc.), political
affiliation (Republican, Democrat, etc.), and ethnicity (Hawaiian, Japanese, etc.).
Note that these cannot be ranked in any logical order.

Ordinal Data: Numbers (or words, but usually numbers) that can be rank ordered
or scaled. Some examples of ordinal data are the place finished in arace (1%, 2",
34 etc.), degrees of happiness (sad, neutral, happy), and level of school
(elementary, middle school, high school, college, etc.). Note however, that these
do not express a degree of magnitude or interval. For example, you could not say
that someone who felt neutral had twice as much “happiness’ than a person who
was sad. You could not say that the amount of time between the first place and
second place runner was the same as the amount of time between the second and
third place runner.

Numeric Data: Numbers that can be rank ordered or scaled, that do express a
degree of magnitude, that have consistent intervals. Some examples of numeric
data are test scores, time, and height. Note that with the numeric data of time, 40
minutes is twice as much as 20 minutes, and that the amount of time between 20
to 40 minutes is the same amount of time as the amount of time between 40 and
60 minutes.

What are you looking for? (Thisis pretty obvious!)

Differences: If you are trying to determine if one group is different, greater than,
or less than another group. For example, are men taller than women?

Corrélations: If you are trying to determine if there is arelationship between one
variable and another. For example, does alcohol consumption increase as
unemployment rates increase? If you are looking for a correlation, you do not
need to complete steps 3 and 4.



Guide to SPSS 5

Regressions: |If you are trying to determine if one variable can accurately predict
another variable. For example, can the amount of rainfall predict the amount of
mud dlides? If you are looking for a regression, the variables must be numeric,
and you do not need to complete steps 3 and 4.

Step 3: Between Groups or Within Groups? (aka | ndependent Groups or
Correlated Groups)

If you have a one group test (see step 4 if you do not know what that is), you do
not need to complete step 3.

Between (aka Independent) Groups: When each participant isin only one of the
groups. For example, when comparing men and women, a man would not be in
both groups. Thus, you are testing two (or more) different groups of people.

Within (aka Correlated) Groups: When each participant isin al of the groups.
For example, giving exams to a group of people on three separate occasions and
comparing their scores on the three different exams (here the three “groups’
would be the three test scores). Thus, you are comparing the same group of
people at three different times.

Step 4: One Group, Two Groups, or Morethan Two Groups?
Remember that you are looking at the Independent Variable when you are
determining how many groups your variable has.

One Group: If you are comparing the distribution of one group of people to a
hypothetical or actual population distribution. For example, comparing the ethnic
distribution of the Claremont Colleges with the ethnic distribution of the USA.

Two Groups: For between (aka independent) groups: If you are comparing one
group of peopleto another. For example, comparing men and women. For within
(aka correlated) groups: If you are comparing the same group of people’s test
scores on two separate occasions.

More than Two Groups: For between (aka independent) groups. If you are
comparing more than two groups. For example, comparing students from
Scripps, CMC, HMC, Pitzer, and Pomona. For within (aka correlated) groups: |If
you are comparing the same group of peopl€'s test scores on more than two
occasions.

Step 5: Selecting the Test

See next page
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Step 4: 1 —¥ Chi Sguare Goodness-oi-Fit {15)
Step 3: Batween 4 Step 4: 2 —% Chi Square Independence [15)
“k Step 4: 3+ — Chl Square Independance [15)
Step 2: Diffarenca
E\I W Step 4: 1 — Cni Square Goodness-oi-Fit (15)
Step 3: Within —#= Step 4: 2 —# Cochran’s O (15-18)
Step 1; Nominal e Step 4: 3+ —= Cochran's Q (15-18)

Step 2: Comrelations # Cramars Y & Phi (16}

Step 4: 1 —= Frisdman's (14)
Step 3: Between -+ Step 4: 2 —p Kruskal-Wallis (14)
Step 4: 3 + —P= Krugkal-Wallis {14)
Step 2: Differences
Step 4: 1 —= Friedman's (14)
Step 3; Within = Step 4: 2 —# Friedman's (14)
Stap 1: Ordinal M‘E‘h&p 4: 3 + —=Friedman's (14)

Step 2: Comrelations # Spearman's Garrelation (14}

Step 4; 1 = Ona-Group T-tast® (7-8)
Step 3 Batween = Stap 4 2 —= Independant Groups T-test* (8)
Stop 4: 3 + —p= Ind. Groups ANOVA (10}
Step 2: Differences
Step 4 1 = One-Group T-test” (T-8)
Step 3 Within ﬂsm 4; 2 —p Repeated Maasures T-tast* (9)
Step 4 3 + = Rapeated Groups ANOVA (10)

%‘bﬂp 2: Corralations »  Paarson's Correlation (10-11)

Stap 2: Regressions #  Linear Regression (11-13)

* |f the population mean and the population standard deviation ane known, then you would use a 2z-score;
however, it i highly unlikefy that you will know the population mean and standard deviation (unless you
are testing variables that are asked about in the census), thus the ttest would be the most appropriale
fest 10 use,
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Hints For All Tests

Remember that the Significance (or Asymp. Sig. in some cases) needs to be less
than 0.05 to be significant.

The Independent Variable is dways the variable that you are predicting
something about (i.e. what your Ha predicts differences between, as long as your
Hais correct). The Dependent Variable is what you are measuring in order to tell
if the groups (or conditions for repeated measures tests) are different. For
correlations and for Chi-Square, it does not matter which one is the Independent
or Dependent variable.

Ha aways predicts a difference (for correlations, it predicts that r is different from
zero, but another way of saying thisisthat there is a significant correlation) and
Ho always predicts no difference. If your H, was directional, and you find that it
was predicted in the wrong direction (i.e. you predicted A was greater than B and
it turns out that B is significantly greater than A) you should still accept H,, even
though H, predicts no difference, and you found a difference in the opposite
direction.

If thereisa WARNING box on your Output File, it is usually because you used
the wrong test, or the wrong variables. Go back and double check.

Tests For Numeric Data

Z-Scor es (Compared to Data)

Analyze > Descriptive Statistics> Descriptives

Click over the variable you would like zscores for

Click on the box that says Save Standardized Values as Variables. Thisis
located right below the box that displays all of the variables.

If means and standard deviations are needed, click on Options and click on the
boxes that will give you the means and standard deviations.

The zscores will not be on the Output File!!!

They are saved as variables on the Data File. They should be saved in the
variable that is to the far right of the data screen. Normally it is called z, and then
the name of the variable (e.g. ZSLEEP)

Compare the zscores to the critical value to determine which zscores are
significant. Remember, if your hypothesisis directional (i.e. one-tailed), the
critical valueis + or — 1.645. If your hypothesis is non-directiona (i.e. two-
tailed), the critical valueis + or — 1.96.
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Z-Scores Compar ed to a Population M ean and Standard Deviation:

The methodology is the same except you need to tell SPSS what the population
mean and standard deviation is (In the previous test, SPSS calculated it for you
from the data it was given. Since SPSS cannot cal cul ate the population mean and
standard deviation from the class data, you need to plug these numbersinto a
formula).

Remember the formula for a zscore is:

X-m
Z:
s

You are going to transform the data you got into a zscore that is compared to the
population by telling SPSS to minus the population mean from each piece of data,
and then dividing that number by the population standard deviation. To do so, go
to the DATA screen, then:

Transform - Compute

Name the new variable you are creating in the Target Variable box
(ZUSPOP isagood one if you can't think of anything).

Click the variable you want zscores for into the Numeric Expression box.
Now type in the zscore formula so that SPSS will transform the datato aUS
population zscore. For example, if | am working with a variable called Sleep,
and | am told the US population mean is 8.25 and that the US population
standard deviation is .50, then my Numeric Expression box should look like
this:

(SLEEP-8.25)/.50
Compare for significance in the same way as above.

For All T-Tests

Thesignificancethat isgiven in the Output Filei s a two-tailed significance.
Remember to divide the significance by 2 if you only have a one-tailed test!

For One Group T-Tests

Analyze > Compare Means-> One-Sample T Test

The Dependent variable goes into the Test Variables box.

The hypothetical mean or population mean goes into the Test Value box. Be
Careful!!! The test value should be written in the same way the data was
entered for the dependent variable. For example, my dependent variable is
“Percent Correct on aTest” and my population mean is 78%. If the data for
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the “Percent Correct on a Test” variable were entered as 0.80, 0.75, €tc., then
the vest value should be entered as 0.78. If the data were entered as 90, 75,
etc., then the test value should be entered as 78. In order to know how the
data were entered, click on the Data File screen and look at the data for the
dependent variable.

For Independent Groups T-T ests

Analyze > Compare Means—-> Independent-Samples T Test

The Dependent Variable goes in the Test Variable box and the Independent
variable goes in the Grouping Variable box.

Click on Define Groups and define them. In order to know how to define them,
click on Utilities-> Variables. Click on the independent variable you are
defining and see what numbers are under the value labels (i.e. usualy it's either O
and 1 or 1 and 2). If there are more than two numbers in the value labels then you
cannot do at-test unless you are using a specified cut-point (i.e. if there are four
groups: 1 = old women, 2 = young women, 3 = old men, 4 = young men, and you
simply wanted to look at the differences between men and women, you could set
acut point at 2). If there are no numbers, you should be using a specified cut-
point. If you have more than two numbers in the value labels, or if you have no
numbers in the value labels, and no cut-point has been specified on the final exam
you are doing the wrong kind of test!!!!

On the Output File: Remember, thisis at-test, so ignore the F value and the first
significance value (Levene's Test). Also, ignore the equal variances not
assumed row.

Before accepting Ha, be sureto ook at the means!!! If | predict that boys had a
higher average correct on atest than girls and my t-test value is significant | may
say, Yyes, boys got more correct than girls. However, this t-test could be
significant because girls got significantly more correct than boys!! (Therefore, Ha
was predicted in the wrong direction!) In order to know which group got
significantly more correct than the other, | need to look at the means and see
which oneis bigger!!

For Repeated Measures (a.k.a Correlated Groups, Paired Samples) T- Test

Analyze-> Compare Means-> Paired-Samples T Test

Click on one variable and then click on a second variable and then click on the
arrow that moves the pair of variables into the Paired Variablesbox. [In order
to make things easier on yourself, click your variablesin, in order of your
hypotheses. For example, if you are predicting that A is greater than B, click on
Afirst. Thisway, you should expect that your t value will be positive. If thetestis
significant, but your t value is negative, it means that B was significantly greater
than A!! (So Hy was predicted in the wrong direction and you should accept Ho).

If you are predicting that A isless than B, then click on Afirst. Thisway, you
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should expect that the t value will be negative. If the test is significant but the t
value is positive, you know that it means that B was significantly less than A (so
Ha was predicted in the wrong direction, and you should accept Hy).]

For Independent Groups ANOVA

Analyze > Compare Means—> One-Way ANOVA

Put the Dependent variable into the Dependent List box. Put the Independent
variable into the Factor box.
Click on the Post Hoc box. Click onthe Tukey box. Click Continue.

If means and standard deviations are needed, click on the Options box. Then
click on Descriptive.

For Repeated M easures (a.k.a. Correlated Groups, Paired Samples) ANOVA

Analyze> General Linear Model > Repeated Measures

Type in the within-subject factor name in the Within-Subject Factor Name box.
This cannot be the name of a pre-existing variable. Y ou will have to make one
up.

Type in the number of levelsin the Number of levels box. How do you know
how many levels there are? If my within-subject factor was “ Tests’ and | have a
variable called “Test 17 avariable called “Test 2" and avariable called “ Test 3,”
then | would have 3 levels. In other words, the number of levels equals the
number of variables (that you are examining) that correspond to the within-
subject factor.

Click on Define.

Put the variables you want to test into the Variables box. Preferably, put themin
the right order (if there is an order to them). Thiswill keep you from getting
confused. For example, | should put in my “Test 1” variable in first, my “Test 2"
variable in second, etc.

For post hoc tests, click on Options, highlight the variable, move it into Display
Means For box, click on Compare Main Effects, change Confidence I nterval
Adjustment to Bonferonni (the closest we can get to Tukey’s Test). You may
also want to click on Estimates of Effect Size for etaf.

Remember to look at the Tests of Within-Subjects Effectsbox for your ANOVA
results.

Pearson’s Correlation Coefficient (r)

Analyze > Correlate-> Bivariate

Make sure that the Pear son box (and only the Pear son box) has a check in it.
Put the variables in the Variables box. Their order is not important.
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Sdlect your tailed significance (one or two-tailed) depending on your hypotheses.
Remember directional hypotheses are one-tailed and nontdirectional hypotheses
are two-tailed.

If means and standard deviations are needed, click on Options and then click on
Means and Standard Deviations.

Linear Regression

Graphs-> Scatter > Smple

This will let you know if there is alinear relationship or not.

Click on Define.

The Dependent variable (criterion) should be put in the Y-axis box and the
Independent variable (predictor) should be put in the X-axis box and hit OK.

In your Output: Double click on the scatterplot. Go to Chart > Options. Click
on Total inthe Fit Line box, then OK.

Make sure it is more-or-less linear. The next step is to check for normality.

Graphs-> Q-Q

Put both variables into the Variable box. Hit OK.

Look at the Normal Q-Q Plot of ...., not the Detrended Normal Q-Q of ...
box. If the pointsare a“smiley face” they are negatively-skewed. This means
you will have to raise them to a power greater than one. If the points make a
“frown face” then they are positively-skewed. This means you will have to
raise them to a power less than one (but greater than zero). To do this, goto
the DATA screen then:

Transform - Compute

Give the new variable a name in the Target Variable box. Since you will
be doing many of these (because it is a guess and check) it may be easiest
to name it the old variable and then the power you raised it to. For
example, SLEEP.2 if | raised it to the .2 power, or SLEEP3 if | raised it to
the third power.

Click the old variable (that you want to change) into the Numeric
Expressions box. Type in the exponent function (**), and then the power
you want to raise it to. Hit OK.

Redo the Q-Q plot with the NEW variable (i.e. SLEEP.2, and not SLEEP).
Repesat until you have the best fit data. The variable that you created with
the best-fit data (i.e. SLEEP.2) will be the variable that you will use for
the REST OF THE REGRESSION (no more SLEEP).

The next step isto remove Outliers. To do so, run aregression:

Analyze-> Regression - Linear
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The Independent variable is the predictor (the variable from which you want to
predict). The Dependent variable is the Criterion (the variable you want to
predict).

Click on Save and then click on Cook’s Distance. Like the zscores, these values
will NOT bein your Output file. They will be on your Datafile, saved as
variables (COO-1).

Do aBoxplot:

Graphs-> Boxplot

Click on Simple and Summaries of Separate Variables.
Put Cook’ s Distance (COO _1) into the BoxesRepresent box. Put avariable
that will label the cases (usually 1D or name) into the L abel Cases by box.
Double click on the Boxplot in the Output file in order to enlarge it and see
which cases need to be removed (those lying past the black lines). Keep track
of those cases. (Some people prefer to take out only extreme outliers, those
marked by a*.)
Go back to the Datafile. Find a case you need to erase. If you highlight the
number to the far Ieft (in the gray), it will highlight all of the data from that
case. Then goto Edit > Clear. Repeat thisfor al of the outliers. ERASE
FROM THE BOTTOM OF THE FILE, WORKING UP; IF YOU DON’'T
THE ID NUMBERSWILL CHANGE AND YOU'LL ERASE THE
WRONG ONES! DO NOT RE-RUN THE BOXPLOT LOOKING FOR
MORE OUTLIERS! Once you have cleared the outliers from the first (and
hopefully only) boxplot, you can continue.
Now re-run the regression.
Remember: R tells you the correlation. R tells you the proportion of variance
in the criterion variable (Dependent variable) that is explained by the predictor
variable (Independent variable). The F tells you the significance of the
correlation. The predicted equation is: (B constant) +
(Variable constant)(Variable). Where B constant is the number in the column
labeled B, in the row labeled (constant), and where Variable constant is the
number in the column labeled B and in the row that has the same name as the
variable [under the (constant) row].
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Tests For Ordinal Data

Remember, since thisis ordinal data, you should not be predicting anything about
means in your Haand Ho. Also, you should not be reporting any means or
standard deviations in your results paragraphs.

Therefore, if you need to report medians and/or ranges go to Analyze >
Descriptive Statistics2> Frequencies. Click on Statistics and then click on the
boxes for median and for range.

Kruskal-Wallis

Analyze > Nonparametric Tests=> K Independent Samples

Make sure the Kruskal-Wallis H box (and this box only) has a check mark in it.
Put the Dependent variable in the Test Variable List box and put the
Independent variable in the Grouping Variable box.

Click on Define Range. Type in the min and max values (if you do not know
what they are you will have to go back to Utilities—> Variablesto find out and
then come back to this screen to add them in).

Friedman’s Test

Analyze > Nonparametric Tests> K Related Samples

Make sure that the Friedman box (and only that box) has a check mark in it.
Put the variables into the Test Variables box.

In the Output File: Even though it says Chi-Square, don’t worry, you did a
Friedman’s test (as long as you had it clicked on).

Spearman’s Correation (rs)

Analyze-> Correlate-> Bivariate

Click on the Pear son box in order to turn it OFF! Click on the Spear man box in
order to turn it ON!

Choose a one or two-tailed significance depending on your hypotheses.

Put variables into the Variable box.
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Testsfor Nominal Data

Remember, since thisis for nomina data, your hypotheses should not be
predicting anything about means. In addition, you should not be reporting any
means, standard deviations, medians, or ranges in your results paragraphs.

In order to determine the mode go to Analyze > Descriptive Statistics>
Frequencies. Click on the Statistics box and then click on the mode box.

Chi-Squar e Goodness-of-Fit

Analyze-> Nonparametric Tests=> Chi Square

Put the variable into the Test VariableList.

If al of the levelsin your variable are predicted to be equal, click on All
Categories Equal.

If thereis apredicted proportion that is not all equal (i.e. 45% of the US
population is male and 55% is female) then you need to click on the Values box.
In order to know which value you enter in first (i.e. 45% or 55%) you need to
look at which one (male or female) was coded first. To do this, go to Utilities>
Variables and click on the variable you are interested in. The one with the
smallest number (i.e., if male was coded as 1 and female was coded as 2, males
would have the smaller number) is the one whose predicted percentage gets
entered first. In this case, since male was coded as one, the first value | would
enter into the Values box would be 45%. The second would be 55%.

Chi-Squar e | ndependence

Analyze > Descriptive Statistics> Crosstabs

Put one variable into the Rows box and one into the Columns box. It does not
matter which variable is put into which box.

Click on Statistics. Click on Chi-Square.

In the Output File: Look at one of the two boxes that compare variable A to
variable B. Ignore the box that compares variable A to variable A, and the box
that compares variable B to variable B (you will know which ones these are
because they have a chi-square value of 1.00 — a perfect correlation because it
correlated with itself).

Cochran’sQ
Analyze-> Nonparametric Tests> K Related Samples

Click on Friedmanto turn it OFF! Click on Cochran’s Q to turn it ON!
If there are more than two groups, and you need to tell which groups are
significantly different from each other, the only way you can do thisis by doing
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many Cochran’s Q tests using only two groups. Therefore, you have to test every
combination. For example, if there are three groups, you have to do one
Cochran’s Q test between group 1 and 2, one test between group 1 and 3, and one
test between group 2 and 3 (so let’s hope he doesn’t ask you to do that!!).

Cramer’sV or Phi (Corréation for Nominal Data)

Do a Chi-Square Independence except you need also to click on Statistics and
then click on the Phi and Cramer’sV box, and the Contingency Coefficient

box.



